WordPress升级到3.4后台不能编辑主题的解决办法

WordPress升级到3.4后台不能编辑主题的解决办法

CludeChn
2012-06-18 / 0 评论 / 1,165 阅读 / 正在检测是否收录...
温馨提示:
本文最后更新于2012年06月18日,已超过4417天没有更新,若内容或图片失效,请留言反馈。

估计大家在升级到Wordpress 3.4完毕之后,发现后台有点问题,点击appearance(主题),只能看见升级之前所用的主题,别的主题都看不到,点击Editor(编辑),则出现下面的错误:

Warning: scandir() has been disabled for security reasons in ...
Warning: Invalid argument supplied for foreach() in ...

下面还有一行

Oops, no such file exists! Double check the name and try again, merci.

解决办法如下:

vi php.ini

php.ini的具体路径在phpinfo中可以看到。在php.ini文件中找到 disable_functions 字符串,把后面的scandir 删除,然后 :wq 退出。重启服务器,即可。

来源:http://imdoc.net/archives/1940

0

评论 (0)

取消